WP SimpleWeather was created and tested using WordPress 3.0 and newer. It may not work correctly on older versions of WordPress. Update to the latest version of WordPress now.